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Seagate Info Report Design


TOPIC 3                                      INFO REPORT DESIGNER

PURPOSE

The purpose of this topic is to discuss the main features of the Info Report Designer.  We will take a look at the functionality of the tool as well as the location of all its components.

OBJECTIVES

By the completion of this topic, you will be able to:

· Navigate comfortably within the Info Report Designer

· Identify the main features of the Design tab and the Preview tab

Opening a report within Info Report Designer

Last time we showed you the shortcut to opening an existing report in the design tool by right-clicking on the object and selecting Design.  This time, we will use the Info Report Designer to open the report.
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INFO DESIGNER TOOL
Info Report Designer

Step 1
Select the Info Report Designer icon from the tool bar.  The Welcome screen opens.
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Step 2
On the Welcome screen.  Select Open and Existing Report.
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Open 
Step 3
On the Open dialog box, select MRDB(2) the folder and the Object Template(2).

Step 4
Click the <OK> button.
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INFO DESIGNER MAIN SCREEN
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· The Title Bar indicates the report that you have opened as well as the standard Windows buttons to control the window size.

· The Menu Bar is similar to any other in a Windows based software package.

· The Standard Toolbar appears just below the Menu Bar.

· The Format Bar appears just below the Standard Toolbar.

· If toggled on, the Supplementary Toolbar will become available.

· Finally, the Status Bar is at the bottom of the Main window.

MENU BAR
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You can think of the Menu Bar as the command center of the Info Report Designer.  Each of the options acts as a dropdown menu which provides you with further choices to select from.

The File menu includes options like opening, closing and saving your reports.  Your printing and exporting options are also located here.  For a complete list of these menu options, search for File Menu Commands in the Info Report Designer online Help.

The Edit menu uses commands that will modify the aspects of your report.  It includes the familiar undo and redo commands.  This is where you would edit the formulas and fields contained in your report.

The View menu allows you to either show or hide some of your toolbars.  You can zoom in and out of your report from here.  

The Insert menu is where you will pull in database fields from your MRDB views.  Other fields that you will be inserting like text objects, parameters, formula fields and subtotals will be found under this menu as well.

The Format menu is where you will change how your report will look.  Options such as font characteristics, background colors and field formatting will be found here.

The Database menu is where you will add and delete database tables from your report.  Recall that we used this menu option for one of our previous examples.  You can also Log On and Off the servers from here.  You can verify the database and set the location of the database.

The Report menu is where you will select records or groups within your report.  You can also modify the sort order of your report from here.

The Window menu allows you to rearrange the icon and windows.  You can close all report windows opened at once from this menu item.

The Help menu is where you will access an abundance of information pertaining to all aspects of report design.  You may either view the major topics of the designer or perform a search based on user input.

THE STANDARD TOOLBAR
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Standard Toolbar 

The Info Report Designer groups commonly used commands on the standard toolbar that will remain on screen at all times.  These tools are the same as the commands we discussed in the Menu Bar.  The icons next to the choices in the Menu Bar correspond to the same icons that are displayed in the standard toolbar.  You can hold your mouse pointer over any of these icons to display it’s command.

While the toolbar supplies a short-cut to activating the commands of the Info Report Designer, right-clicking in various sections of the report will also display these tools.  We will use all three methods (Menu Bar, Toolbar, Right-Clicking) throughout this course to allow you to get comfortable with the navigation.

SUPPLEMENTARY TOOLBAR
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Supplementary Toolbar

This toolbar provides quick access to many advanced, report-enhancing experts and features.  In order to activate this toolbar, you must click the Supplemental Toolbar button [image: image5.bmp] found on the far right of the Format bar.

Take a look at the picture of this toolbar above. You will notice that when you drag your cursor over one of the buttons, both the command and details of the button’s function will be displayed.  In our screen capture, we displayed the Link Expert which will “Visually link tables in report using expert” in the Status Bar.

FORMAT BAR
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Format Bar

This toolbar will enable you to access many popular formatting commands.  Simply select the data to format, then click the appropriate button or list option to format the data.  The two options on the left side of this toolbar are for selecting font styles and sizes.  Again, you can drag your cursor over any of these to get a description of its function.

STATUS BAR
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Status Bar

The Status Bar is located at the bottom of the window.  It contains some valuable information that needs to be pointed out.  When your cursor is over a toolbar or format bar option, the status bar will display a short description of the button’s function.  Looking at the screen shot on the following page we can see an example of this.  The example shows that a Print Date field was highlighted which prompted the status bar to display that field and width and height information from the field.

Shortcut Menus

We discussed how right-clicking on an object or section of the report would prompt a shortcut menu to appear.  You will find that using this shortcut will speed up your work tremendously.  Unlike the program’s standard menu’s that group commands by function, shortcut menus are element-specific.  This means that they will only display those commands that will work on the selected element.

Cursors

The Info Report Designer uses various cursors at different points in its operation.  Take a look at the help menu to review some of these.

DESIGN TAB
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Design Tab

The Design tab is where you will probably spend the majority of your time while designing a report.  This is where you will place your report name and other text fields, probably in the header section.  This is where you will place all your database fields, groups, subtotals, and any other summary information.

When a field is placed on the report, the program uses a frame to identify it on the template; it does not retrieve the data.  This is a very important point.  Therefore, fields and other objects can be added and/or deleted, moved around, set up with complex formulas, and more, without tying up the computer or network resources it takes to gather the data.

The reports you will create in this Design tab are actually virtual reports.  They have the structure and instructions for creating the final report, but it is not the report itself.  To turn the Design tab report into a final report, “just add data.”  You do this whenever you preview the report, print it, or output it in any other way.

DESIGN TAB AREAS
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Upon opening or creating a new report, the Info Report Designer automatically creates five main areas in the Design tab.

The Report Header can be used for the report title and any other information that is to be displayed at the beginning of the report.

The Page Header is for information that is to be displayed at the top of each page.  This is used generally for the data field names and line amounts.  If you want the title of the report to be displayed on every page you would place it in the page header.

The Details is used for the body of the report.  These sections will be printed once for each record.  The majority of the report data will be displayed in this section.

The Report Footer is used for information that you would like to appear only once at the end of the report, such as grand totals for your expenditures, revenues, etc.

The Page Footer is generally used for displaying the page number.

GROUP HEADER AND GROUP FOOTER
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Group Header and Group Footer

If you add a group, a summary or a subtotal to your report, the program will create two additional sections.

The Group Header holds the group name field.  This section is printed once at the beginning of a group.  For example, if you were to group your report by agency number, you could call this group ‘Agency’ and have it appear at the start of each new agency grouping.

The Group Footer holds any summary values that are present, if any, and can be used to display graphs.  It is printed once at the end of a group.

How Often Objects Print

In order to place information in your report, it is important to fully understand how often each piece of information will print.

Objects placed in the Report Header area print once, at the beginning of the report.  Formulas placed in this area are evaluated once, again, at the beginning of the report.

Objects placed in the Page Header area print at the beginning of each new page.  Formulas placed in this section are evaluated once per page, at the beginning of each new page.

Objects placed in the Group Header area print at the beginning of each new group.  Formulas placed in this area are evaluated once for each group, at the beginning of the group.

Objects placed in the Details area print with each new record. 

Objects placed in the Group Footer area print at the end of each group.  Objects placed in the Page Footer area print at the bottom of each page.  Objects placed in the Report Footer area print once at the end of the report.

PREVIEW TAB
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Previewing a Report

Whenever you want to preview your report before printing or saving, click the Print Preview button on the Standard Toolbar.

You can view the report by clicking on the <Print Preview> button  [image: image12.bmp] on the Standard Toolbar when on the Design tab.

This will cause the program to gather the data from the MRDB, perform any calculations or formulas supplied and display the report in the Preview tab on ‘electronic paper.’  With all your data in place, you have the ability to review the spacing and formatting of your report and see the actual results of your summaries, groups, totals, etc.  From here, you can click on the Design tab, make any necessary changes, and look at the results again from the Preview tab.

GROUP TREE VIEW
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Group Tree

You may toggle the Group Tree view on and off by clicking on the toolbar button  [image: image14.bmp]  as indicated on the screen shot.  When using the Group Tree, you will notice a split screen appear.  The right pane displays the actual report and the left pane displays a high-level outline of the report.  This outline shows the hierarchy of groups and subgroups in a familiar tree format.

When you click a tree node that interests you, the program jumps immediately to the part of the report that contains the information for that group.  This tool can save tremendous amounts of time when jumping back and forth through the various sections of your report.

MOVING AND RESIZING TOOLBARS
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MOVING

Step 1     Click on the Design Tab in the Info Report Designer.

Step 2     Click and hold on a toolbar where there is no button and drag the bar to a new position.

Step 3   Release the mouse button and your toolbar should now reside in the place/position that you dragged it to.

RESIZING

Step 1     Position your mouse pointer over an edge or corner of the bar.  

Step 2   When the resizing pointer appears [image: image16.bmp], drag it inward or outward to resize the bar.

Step 3
You may close out of the Info Report Designer at this time and when asked if you would like to save your changes, click the <NO> button.


In this topic we have learned how to:

· Navigate comfortably within the Info Report Designer

· Identify the main features of the Design tab and the Preview tab
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Are there any questions concerning the information covered in this topic?
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